Skip to content

Apiary deployment with ECS type metastore service is failing after adding support for K8s #136

Description

@anuatgithub

We are trying to upgrade our apiary version from 1.0.0 to 4.0.0 or above, and we are using 'ecs' for hms_instance_type variable. while deploying this change from rundeck, terraform plan failed with below error.

Error: Failed to initialize config: stat /var/lib/rundeck/.kube/config: no such file or directory

Looks there is bug in K8s supported code which breaks the ECS deployment. If i add valid kube config file on rundeck server, the plan succeeding. Please let me know if there is any workaround for this without adding kube config file.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions